Press "Enter" to skip to content

Minisforum U820 安装 esxi6.7 – ESXI打包网卡驱动 【失败了】

最近买了台minisforum的U820,想装个esxi来玩虚拟化。

买之前以为会一切顺利,到货后准备兴冲冲的灌系统,然后发现问题没那么简单。。。

结论

我没有搞成功,失败了,放弃了!这个机器有2个网卡。2.5G的卡只能在7.X打驱动,1G的网卡最高只能打到6.7的驱动。所以如果想玩all in one,不建议搞这个机器。建议搞双千兆或者双2.5G的版本。

背景

下载好esxi7.0的系统准备开始在 U820上安装的时候发现,No Network Adapters 的提示信息。

我擦了?难道要插着网线装系统吗?

插了网线并没有卵用,想了想应该是esxi7.0是不是太新了,不兼容我们U820的网卡了。然后我又装了个esxi6.7的优盘,试了一把,还是提示这个。6.7是我容忍的最低版本了,没法再往下面试了。

查查资料,看看到底哪里不兼容呗,先要看下我们设备是什么网卡,查了很多资料,官网也只显示我们U820是千兆+2.5G网卡,或者 双千兆网卡,也不说是啥型号。

又查了些资料,大概看到我们的设备应该是螃蟹(Realtek)的网卡,然后我就又搜了关键词 ESXI 螃蟹网卡,我靠,果然好像是不支持。然后说要自己打包个带网卡驱动的esxi安装包。

好吧,那我们试试看吧。

打包带Realtek驱动的esxi安装包

参考资料:

https://www.youtube.com/watch?v=Vud1suosrBU

参考资料文字版:

How to add Realtek driver into VMWare ESXi 6.7 ISO ?
[ SEVERAL STEPS ]

Allow scripts to run as administrator option:
$   Set-ExecutionPolicy Unrestricted 
$   Install-Module -Name VMware.PowerCLI
$   Set-PowerCLIConfiguration -Scope User -ParticipateInCEIP $true

Create a new software depot using the two bundles:
$  Add-EsxSoftwareDepot "C:\Users\[USERNAME]\Desktop\net55-r8168-8.045a-napi-offline_bundle.zip", "C:\Users\[USERNAME]\Desktop\VMware-ESXi-6.7.0-8169922-depot.zip"

Next, create a new image profile:
$  Get-EsxImageProfile
$  New-EsxImageProfile -CloneProfile ESXi-6.7.0-8169922-standard -name ESXi-6.7.0-8169922-standard-RTL8111 -Vendor Razz 
$  Set-EsxImageProfile -ImageProfile ESXi-6.7.0-8169922-standard-RTL8111 -AcceptanceLevel CommunitySupported

Add the driver to image profile:
$  Get-EsxSoftwarePackage | Where {$_.Vendor -eq "Realtek"}
$  Add-EsxSoftwarePackage -ImageProfile ESXi-6.7.0-8169922-standard-RTL8111 -SoftwarePackage net55-r8168

And generate the vSphere 6.7 ISO containing the driver:
$  Export-EsxImageProfile -ImageProfile ESXi-6.7.0-8169922-standard-RTL8111 -ExportToIso -filepath C:\Users\[USERNAME]\Desktop\VMware-ESXi-6.7.0-8169922-RTL8111.iso

我们需要使用到2个东西

  • 需要 ESXI 的 Offline Bundle (离线 depot)
  • 需要使用到Realtek的网卡驱动

网卡驱动在 https://vibsdepot.v-front.de/wiki/index.php/Net55-r8168 这个网站最下面的链接下载,下载 Offline Bundle of version 8.045a 这个。

esxi的的offline depot 在VMware官网下载,或者自己尝试别的办法能下载到也行, 我从官网没下载到,然后找的VMware-ESXi-6.7.0-20191201001s-depot.zip这个版本,从国内下的。

然后你还需要一个windows下面的powershell环境,用来打包镜像。

有了这些东西,参考上面的参考资料基本上是能打包出来带驱动的安装包的。

由于我使用的是 VMware-ESXi-6.7.0-20191201001s-depot.zip 这个包, 我这里贴下我的命令。

我先把 VMware-ESXi-6.7.0-20191201001s-depot.zip和 驱动 net55-r8168-8.045a-napi-offline_bundle.zip放到c盘的根目录下面。

Set-ExecutionPolicy Unrestricted 

Install-Module -Name VMware.PowerCLI

Set-PowerCLIConfiguration -Scope User -ParticipateInCEIP $true

Add-EsxSoftwareDepot "C:\VMware-ESXi-6.7.0-20191201001s-depot.zip", "net55-r8168-8.045a-napi-offline_bundle.zip"


New-EsxImageProfile -CloneProfile ESXi-6.7.0-20191201001s-standard -name ESXi-6.7.0-20191201001s-standard-RTL8111 -Vendor Razz 

Set-EsxImageProfile -ImageProfile ESXi-6.7.0-20191201001s-standard-RTL8111 -AcceptanceLevel CommunitySupported

Add-EsxSoftwarePackage -ImageProfile ESXi-6.7.0-20191201001s-standard-RTL8111 -SoftwarePackage net55-r8168

Export-EsxImageProfile -ImageProfile ESXi-6.7.0-20191201001s-standard-RTL8111 -ExportToIso -filepath C:\VMware-ESXi-6.7.0-20191201001s-RTL8111.iso

最后生成的iso文件就在c盘根目录下面。

这里有个坑要说下,首选,你需要科学上网,不然这个VMware.PowerCLI你是安装不上的。

其次,我中途换过一次机器,然后发现装不上VMware.PowerCLI,提示找不到程序包提供程序 nuget 然后找到个解决方案,试了靠谱。

参考资料:https://www.alitajran.com/unable-to-install-nuget-provider-for-powershell/

[PS] C:\>Set-ItemProperty -Path 'HKLM:\SOFTWARE\Wow6432Node\Microsoft\.NetFramework\v4.0.30319' -Name 'SchUseStrongCrypto' -Value '1' -Type DWord

[PS] C:\>Set-ItemProperty -Path 'HKLM:\SOFTWARE\Microsoft\.NetFramework\v4.0.30319' -Name 'SchUseStrongCrypto' -Value '1' -Type DWord

#重启你的powershell

[PS] C:\>Install-Module PowershellGet -Force
 
NuGet provider is required to continue
PowerShellGet requires NuGet provider version '2.8.5.201' or newer to interact with NuGet-based repositories. The NuGet provider must be available in 'C:\Program Files\PackageManagement\ProviderAssemblies' or
'C:\Users\administrator.EXOIP\AppData\Local\PackageManagement\ProviderAssemblies'. You can also install the NuGet provider by running 'Install-PackageProvider -Name NuGet -MinimumVersion 2.8.5.201 -Force'. Do you want PowerShellGet to install
and import the NuGet provider now?
[Y] Yes  [N] No  [S] Suspend  [?] Help (default is "Y"): Y

这样就OK了。

中间我有尝试拿esxi7.0的bundel来打驱动,提示我什么版本不对,没成功,最后还是用的6.7。

这样看起来好像一切顺利了,后面还遇到一个坑。

在我用打了驱动的优盘引导安装的时候提示我 uefi secure boot failed ,感觉可能是我修改了安装包之类的,提示我什么安全引导失败,然后网上查了资料说要关闭安全的uefi引导,进到bios,里面还真有个secure boot control 选项,关闭就行了。

然后后面一切都顺利,顺利识别到网卡,然后安装。

7 Comments

    • admin
      admin 2021年5月31日

      放弃了,2.5G的卡只能在7.X打驱动,1G的网卡最高只能打到6.7的驱动。

  1. Alec
    Alec 2021年6月15日

    打了2.5G网卡驱动的ESXI 7.O的安装包能发我一个么?

    • admin
      admin 2021年6月17日

      你还要吗?

  2. Alec
    Alec 2021年6月15日

    我有个方案,ESXI 7.O里面装个爱快,螃蟹卡直通到到爱快里做WLAN,2.5G网卡用作管理和LAN口,这样也能实现all in one

    • admin
      admin 2021年6月17日

      螃蟹卡 esxi都识别不到,怎么直通啊。。

  3. ben chen
    ben chen 2021年7月16日

    我也是U820,能把你打包好的2.5G ESXI给我一下吗?我给你发个小红包,加个好友

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注